summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2019-12-04 13:58:21 +0100
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2019-12-20 20:52:40 +0100
commit6f314f1cc42a95831228abf1ff771a21223d5fbd (patch)
tree957fd100f0e13e800604aada7e69e1038ed04124 /src/Makefile.am
parentec5ecd1c63d0e09792127705b8806a0931350471 (diff)
downloadgnutls-6f314f1cc42a95831228abf1ff771a21223d5fbd.tar.gz
gnutls-cli: benchmark-tls-kx can work with sub-ms accuracy
This allows micro and nanoseconds to be reported if necessary, and it changes reporting of sample variance to standard deviation giving a possibly better overview as it is in the same units as the average. Signed-off-by: Nikos Mavrogiannopoulos <nmav@redhat.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 9e16698916..92762fa88a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -160,7 +160,7 @@ BENCHMARK_SRCS = benchmark-cipher.c benchmark.c benchmark.h benchmark-tls.c
gnutls_cli_SOURCES = cli.c common.h common.c \
socket.c socket.h ocsptool-common.c inline_cmds.h \
$(BENCHMARK_SRCS)
-gnutls_cli_LDADD = ../lib/libgnutls.la
+gnutls_cli_LDADD = ../lib/libgnutls.la -lm
if ENABLE_DANE
gnutls_cli_LDADD += ../libdane/libgnutls-dane.la
endif