summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2015-12-01 10:40:23 +0100
committerNikos Mavrogiannopoulos <nmav@redhat.com>2015-12-01 10:40:25 +0100
commit72db5d6cd47327c48464eb5cdf042eb04abe0398 (patch)
tree8e0f4e4c2a602fc2f20ff77c3147bc90854a206e /src/Makefile.am
parent40f6e1b863341a276dc71b5d9873ea841f98bd26 (diff)
downloadgnutls-72db5d6cd47327c48464eb5cdf042eb04abe0398.tar.gz
tools: don't compile tpmtool if PKCS11 is disabled
That is because GnuTLS' TPM code makes use of the PKCS11 PIN callbacks.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index b907249c8e..0306af18bd 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -66,13 +66,15 @@ if ENABLE_DANE
bin_PROGRAMS += danetool
endif
+noinst_PROGRAMS = systemkey
+
+if ENABLE_PKCS11
+
+# TPM makes use of PKCS #11 callbacks
if ENABLE_TROUSERS
bin_PROGRAMS += tpmtool
endif
-noinst_PROGRAMS = systemkey
-
-if ENABLE_PKCS11
bin_PROGRAMS += p11tool
endif