summaryrefslogtreecommitdiff
path: root/tests/cert-tests/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2017-01-09 08:46:01 +0100
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2017-01-09 08:46:01 +0100
commite0d66aadb2a7d4e724a3b50ff377c30f3b90965c (patch)
treef3a7e8613835d1eb06f7603880fc86247d883ad6 /tests/cert-tests/Makefile.am
parent5b31e88d170df6ce07187fbc397cb8e3e1dcb59c (diff)
downloadgnutls_3_3_26.tar.gz
tests: do not run key-tests and cert-tests under leak sanitizergnutls_3_3_26
The reason is that we cannot distinguish between a memory leak on application failure (which is followed by exit- thus should be ignored) and an address sanitizer issue (which should never be ignored). As such we disable leak detection with asan and rely on valgrind. Signed-off-by: Nikos Mavrogiannopoulos <nmav@gnutls.org>
Diffstat (limited to 'tests/cert-tests/Makefile.am')
-rw-r--r--tests/cert-tests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/cert-tests/Makefile.am b/tests/cert-tests/Makefile.am
index 6092513449..cd326c3b2f 100644
--- a/tests/cert-tests/Makefile.am
+++ b/tests/cert-tests/Makefile.am
@@ -49,6 +49,7 @@ TESTS += dane
endif
TESTS_ENVIRONMENT = EXEEXT=$(EXEEXT) \
+ ASAN_OPTIONS="detect_leaks=0:exitcode=6" \
LC_ALL="C" \
VALGRIND="$(VALGRIND)" \
LIBTOOL="$(LIBTOOL)" \