summaryrefslogtreecommitdiff
path: root/gir/meson.build
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2018-12-14 11:21:29 +0100
committerChristoph Reiter <reiter.christoph@gmail.com>2018-12-16 12:51:58 +0100
commit9c339f8b0d73c3475edeab37c52dbf991f67b7fa (patch)
tree0b87aeb20b2b8f17076d90510b68f1d02410891a /gir/meson.build
parentc0dd66c3f6cf25404124b5a4d2e49f5cdc9b7110 (diff)
downloadgobject-introspection-9c339f8b0d73c3475edeab37c52dbf991f67b7fa.tar.gz
girepository: Add version macros and functions. Fixes #200
This adds the following macros and functions: GI_MAJOR_VERSION, GI_MICRO_VERSION, GI_MINOR_VERSION, GI_CHECK_VERSION, gi_get_major_version,gi_get_micro_version, gi_get_minor_version. Since we share a prefix with glib we have to namespace these by using the gi_ prefix. g_gi would also work but we already export symbols with gi_ like gi_cclosure_marshal_generic(), gi_type_tag_get_ffi_type() and gi_type_info_extract_ffi_return_value(), so let's not add another naming scheme.
Diffstat (limited to 'gir/meson.build')
-rw-r--r--gir/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/gir/meson.build b/gir/meson.build
index 3de41840..0c50fc86 100644
--- a/gir/meson.build
+++ b/gir/meson.build
@@ -387,6 +387,7 @@ gir_files += custom_target('gir-gio',
girepository_command = scanner_command + [
'--identifier-prefix=GI',
'--symbol-prefix=g',
+ '--symbol-prefix=gi',
'--c-include=girepository.h',
'--namespace=GIRepository',
'--nsversion=2.0',
@@ -410,6 +411,7 @@ gir_files += custom_target('gir-girepository',
'--include-uninstalled=' + gobject_gir.full_path(),
'--cflags-begin'] + glib_includes + [
'-I' + meson.current_source_dir() + '/../girepository',
+ '-I' + meson.current_build_dir() + '/../girepository',
'-DGI_COMPILATION',
'--cflags-end',
'@INPUT@',