summaryrefslogtreecommitdiff
path: root/girepository/meson.build
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2018-12-14 11:21:29 +0100
committerChristoph Reiter <reiter.christoph@gmail.com>2018-12-16 12:51:58 +0100
commit9c339f8b0d73c3475edeab37c52dbf991f67b7fa (patch)
tree0b87aeb20b2b8f17076d90510b68f1d02410891a /girepository/meson.build
parentc0dd66c3f6cf25404124b5a4d2e49f5cdc9b7110 (diff)
downloadgobject-introspection-9c339f8b0d73c3475edeab37c52dbf991f67b7fa.tar.gz
girepository: Add version macros and functions. Fixes #200
This adds the following macros and functions: GI_MAJOR_VERSION, GI_MICRO_VERSION, GI_MINOR_VERSION, GI_CHECK_VERSION, gi_get_major_version,gi_get_micro_version, gi_get_minor_version. Since we share a prefix with glib we have to namespace these by using the gi_ prefix. g_gi would also work but we already export symbols with gi_ like gi_cclosure_marshal_generic(), gi_type_tag_get_ffi_type() and gi_type_info_extract_ffi_return_value(), so let's not add another naming scheme.
Diffstat (limited to 'girepository/meson.build')
-rw-r--r--girepository/meson.build12
1 files changed, 11 insertions, 1 deletions
diff --git a/girepository/meson.build b/girepository/meson.build
index 6a8c5b5d..cc8d8420 100644
--- a/girepository/meson.build
+++ b/girepository/meson.build
@@ -36,6 +36,12 @@ girepo_internals_dep = declare_dependency(
include_directories: include_directories('.'),
)
+gi_version_h = configure_file(
+ configuration: config,
+ input: 'giversion.h.in',
+ output: 'giversion.h',
+)
+
girepo_headers = [
'giarginfo.h',
'gibaseinfo.h',
@@ -58,6 +64,7 @@ girepo_headers = [
'giunioninfo.h',
'giversionmacros.h',
'givfuncinfo.h',
+ gi_version_h,
]
girepo_sources = [
@@ -81,6 +88,7 @@ girepo_sources = [
'gitypeinfo.c',
'gitypelib.c',
'giunioninfo.c',
+ 'giversion.c',
'givfuncinfo.c',
]
@@ -102,6 +110,7 @@ girepo_gir_sources = files(
'gistructinfo.c',
'gitypeinfo.c',
'giunioninfo.c',
+ 'giversion.c',
'givfuncinfo.c',
'giarginfo.h',
'gibaseinfo.h',
@@ -122,7 +131,8 @@ girepo_gir_sources = files(
'gitypes.h',
'giunioninfo.h',
'givfuncinfo.h',
-)
+) + [gi_version_h]
+
install_headers(girepo_headers, subdir: 'gobject-introspection-1.0')