summaryrefslogtreecommitdiff
path: root/girepository/meson.build
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2021-02-23 13:11:22 -0500
committerJohn Ericson <John.Ericson@Obsidian.Systems>2021-05-23 12:56:21 -0400
commitf9c1b6f65bec623d593835c400d2d55d981715c8 (patch)
tree2fbcc56bc165ba6d15268eb2e22588027e2a26d0 /girepository/meson.build
parent00bce5569b5e7fd0f6e373857a89996e07bf0725 (diff)
downloadgobject-introspection-f9c1b6f65bec623d593835c400d2d55d981715c8.tar.gz
Make test suite work with cross-related options
Because of skepticism I received in #224, I made this PR which keeps the testsuite and CI improvements but doesn't add any new build options. I hope this would be less controversial: - no new knobs - tests for those using existing build options - CI tests `build_introspection_data = false`
Diffstat (limited to 'girepository/meson.build')
-rw-r--r--girepository/meson.build7
1 files changed, 0 insertions, 7 deletions
diff --git a/girepository/meson.build b/girepository/meson.build
index c8ef6aa9..786749a9 100644
--- a/girepository/meson.build
+++ b/girepository/meson.build
@@ -185,13 +185,6 @@ girepo_lib = shared_library('girepository-1.0',
install: true,
)
-# Copy to builddir for use with giscanner/dumper.py when running uninstalled
-configure_file(input : 'gdump.c',
- output : 'gdump.c',
- copy: true,
- install_dir: join_paths(get_option('datadir'), 'gobject-introspection-1.0'),
-)
-
girepo_dep = declare_dependency(
link_with: girepo_lib,
dependencies: [glib_dep, gobject_dep, gio_dep, gmodule_dep],