summaryrefslogtreecommitdiff
path: root/giscanner/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2017-11-23 13:45:37 +0530
committerNirbheek Chauhan <nirbheek@centricular.com>2018-03-10 19:05:19 +0530
commit5d15d65e26504b2188ffb42b2bf8a32e22a5add8 (patch)
treeea9f2d4335a23cb188fbb371c2b7c65bc1eefc61 /giscanner/meson.build
parentc2b2a76b00ec0a994426509ccd6b9dedd077f19b (diff)
downloadgobject-introspection-5d15d65e26504b2188ffb42b2bf8a32e22a5add8.tar.gz
meson: Use glib_dep and configinc for girepository
glib_dep is what is actually needed to #include <glib.h>, not gobject_dep. It works incidentally with system gobject/glib but not when built via subprojects.
Diffstat (limited to 'giscanner/meson.build')
-rw-r--r--giscanner/meson.build8
1 files changed, 3 insertions, 5 deletions
diff --git a/giscanner/meson.build b/giscanner/meson.build
index 963fad59..e9a9c3cd 100644
--- a/giscanner/meson.build
+++ b/giscanner/meson.build
@@ -65,16 +65,14 @@ giscanner_lib = static_library('giscanner',
scannerlexer,
],
c_args: giscanner_args,
- dependencies: gio_dep,
+ dependencies: [glib_dep, gobject_dep, gio_dep, gmodule_dep],
)
# TODO: -export-symbols-regex "init_giscanner|PyInit__giscanner"
giscanner_pymod = py3.extension_module('_giscanner', 'giscannermodule.c',
link_with: giscanner_lib,
- dependencies: [
- gobject_dep,
- dependency('python3'),
- ],
+ dependencies: [glib_dep, gobject_dep, gio_dep, gmodule_dep,
+ dependency('python3')],
install: true,
install_dir: giscannerdir,
)