summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2019-01-06 11:29:23 +0100
committerChristoph Reiter <reiter.christoph@gmail.com>2019-01-06 11:29:23 +0100
commit4e1ada2070a2626c82bd510f5165e5557c7d0608 (patch)
tree02d5300426d71d0c4237bea2431c138cde086701 /meson.build
parent6a11cde78591acc37fe9162bcaf26cde10413436 (diff)
downloadgobject-introspection-4e1ada2070a2626c82bd510f5165e5557c7d0608.tar.gz
meson: warn that not all tests will be run if building without cairo/doctool
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 3759c12b..cd647b04 100644
--- a/meson.build
+++ b/meson.build
@@ -151,6 +151,13 @@ if with_cairo
cairo_gobject_dep = cc.find_library ('cairo-gobject')
endif
endif
+else
+ warning('Not building with cairo support, not all tests will be run')
+endif
+
+with_doctool = get_option('doctool')
+if not with_doctool
+ warning('Not building with doctool support, not all tests will be run')
endif
subdir('girepository')