summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2020-07-14 15:51:14 +0000
committerChristoph Reiter <reiter.christoph@gmail.com>2020-07-14 15:51:14 +0000
commit9f9d8cefe966d260cf8c12971dcad40537adb5c6 (patch)
tree1d0eded74c6371848bde389ce7589bd23d65c565 /meson.build
parentbc8d3bc249e8eeff444e5fafac0d8821244fdb26 (diff)
parent89c81712570e98e5ee411275c0fa467a6b61e977 (diff)
downloadgobject-introspection-9f9d8cefe966d260cf8c12971dcad40537adb5c6.tar.gz
Merge branch 'patch-1' into 'master'
[Win32] Fix gi-dump-types.c to build on Windows See merge request GNOME/gobject-introspection!218
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 658727d8..04426515 100644
--- a/meson.build
+++ b/meson.build
@@ -144,12 +144,15 @@ gmodule_dep = dependency('gmodule-2.0', version : glib_version,
if host_system != 'windows'
giounix_dep = dependency('gio-unix-2.0', version : glib_version,
fallback: ['glib', 'libgiounix_dep'])
+ giowin_dep = dependency('', required : false)
else
# Don't even try to look for gio-unix-2.0 on Windows because Meson will
# fruitlessly try to find it in the glib subproject even when we don't want
# it to look in the subproject at all. Just use a not-found dependency.
giounix_dep = dependency('', required : false)
# XXX: Autotools doesn't build girs for gio-win32-2.0, but maybe we should?
+ giowin_dep = dependency('gio-windows-2.0', version : glib_version,
+ fallback: ['glib', 'libgiowin32_dep'])
endif
libffi_dep = dependency('libffi',
fallback : ['libffi', 'ffi_dep'])