summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorMathieu Duponchelle <mathieu@centricular.com>2018-03-08 20:01:59 +0100
committerMathieu Duponchelle <mathieu@centricular.com>2018-04-20 18:27:08 +0200
commit38437d82827de35b34d210d77ce6fb69ac057bea (patch)
tree328871ed31053459cf4062aa2e530d99b91e4d44 /tests/meson.build
parentc8525c461fa7f5f68ccfd9c332e6a6bbdd9090d3 (diff)
downloadgobject-introspection-38437d82827de35b34d210d77ce6fb69ac057bea.tar.gz
tests: expose variables in meson.build
pygobject uses sources from gi's tests folder to build libraries to test against, with autotools it worked by obtaining gidatadir from pkg-config, but this is explicitly prevented by meson's sandbox when gi is built as a subproject.
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build18
1 files changed, 18 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
new file mode 100644
index 00000000..dcb0fc90
--- /dev/null
+++ b/tests/meson.build
@@ -0,0 +1,18 @@
+test_regress_sources = files('scanner/regress.c')
+test_regress_headers = files('scanner/regress.h')
+test_marshalling_sources = files('gimarshallingtests.c')
+test_marshalling_headers = files('gimarshallingtests.h')
+
+test_regress_incdirs = include_directories(['.', 'scanner'])
+
+installed_sources = [
+ 'scanner/regress.c',
+ 'scanner/regress.h',
+ 'gimarshallingtests.c',
+ 'gimarshallingtests.h',
+ 'gitestmacros.h',
+]
+
+install_data(installed_sources, install_dir: join_paths(get_option('datadir'), 'gobject-introspection-1.0', 'tests'))
+
+### TODO: actually test