summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2022-01-11 15:57:37 +0000
committerEmmanuele Bassi <ebassi@gnome.org>2022-01-11 15:57:37 +0000
commit7c1178069f1c58a05ec56a94ca6ba124215a947b (patch)
treef3a110f43f29359426259a01c32ae948f3d03ef5 /tests/meson.build
parenteffb1e09dee263cdac4ec593e8caf316e6f01fe2 (diff)
downloadgobject-introspection-7c1178069f1c58a05ec56a94ca6ba124215a947b.tar.gz
build: Do not use deprecated API
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 48981c60..abb51f58 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -1,4 +1,4 @@
-sub_build_root = join_paths(meson.build_root(), 'subprojects')
+sub_build_root = join_paths(meson.project_build_root(), 'subprojects')
test_env_common_path = []
if glib_dep.type_name() == 'internal' and host_system == 'windows'
test_env_common_path += [
@@ -13,7 +13,7 @@ endif
if libffi_dep.type_name() == 'internal' and host_system == 'windows'
test_env_common_path += [join_paths(sub_build_root, 'libffi', 'src')]
endif
-test_env_common_pypath = [meson.build_root()]
+test_env_common_pypath = [meson.project_build_root()]
test_regress_sources = files('scanner/regress.c')