summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2020-01-14 16:59:45 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2020-01-15 11:02:48 +0800
commitad937bca10be979cc468b8da0d31f40f86ce0851 (patch)
tree32039d6ea9b00ff35ffe20ab10c837b7dfbde7ce /tests/meson.build
parentfbc3657b769bfa156927a6a116d5967d58b5e75e (diff)
downloadgobject-introspection-ad937bca10be979cc468b8da0d31f40f86ce0851.tar.gz
Visual Studio builds: Use -utf-8 where available
This avoids compilation erroring out on C4819 (Unicode handling issue in the Visual Studio compiler), notably when running on Chinese, Japanese and Korean (CJK) locales. This also applies -utf-8 into the cflags passed into the various g-ir-scanner command lines that are used to generate the *.gir files, where -utf-8 is available, so that we don't get flooded with C4819 warnings during the build, and therefore avoid potential mishaps, as C4819 is a real warning that warngs us the code may be incorrectly built.
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 369abac8..f4c57ed7 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -125,6 +125,7 @@ if glib_dep.type_name() == 'pkgconfig'
'--library=everything-1.0',
'-L', meson.current_build_dir(),
'-I', meson.current_source_dir(),
+ extra_giscanner_args,
'@INPUT@',
]
)
@@ -151,6 +152,7 @@ if glib_dep.type_name() == 'pkgconfig'
'--library=gimarshallingtests-1.0',
'-L' + meson.current_build_dir(),
'--c-include="tests/gimarshallingtests.h"',
+ extra_giscanner_args,
'@INPUT@',
]
)