summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorXavier Claessens <xavier.claessens@collabora.com>2020-05-06 14:24:34 -0400
committerXavier Claessens <xavier.claessens@collabora.com>2020-05-06 14:24:34 -0400
commitf8e080d03bb490e3539a2a7e0c4a5e7a20fcd863 (patch)
treef1eec668d91f881e047869352350db7b9c6ea5f6 /tests/meson.build
parent769f886bfa3c7b21815def592eec7279bb123f23 (diff)
downloadgobject-introspection-f8e080d03bb490e3539a2a7e0c4a5e7a20fcd863.tar.gz
Meson: Fix build as subproject
meson.build_root() is the root of the main project, better use meson.current_build_dir() instead.
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build10
1 files changed, 5 insertions, 5 deletions
diff --git a/tests/meson.build b/tests/meson.build
index f4c57ed7..b240749e 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -115,8 +115,8 @@ if glib_dep.type_name() == 'pkgconfig'
'--output=@OUTPUT@',
'--no-libtool',
'--reparse-validate',
- '--add-include-path', join_paths(meson.source_root(), 'gir'),
- '--add-include-path', join_paths(meson.build_root(), 'gir'),
+ '--add-include-path', join_paths(source_root, 'gir'),
+ '--add-include-path', join_paths(build_root, 'gir'),
'--warn-all',
'--warn-error',
'--namespace=Everything',
@@ -141,8 +141,8 @@ if glib_dep.type_name() == 'pkgconfig'
'--output=@OUTPUT@',
'--no-libtool',
'--reparse-validate',
- '--add-include-path', join_paths(meson.source_root(), 'gir'),
- '--add-include-path', join_paths(meson.build_root(), 'gir'),
+ '--add-include-path', join_paths(source_root, 'gir'),
+ '--add-include-path', join_paths(build_root, 'gir'),
'--warn-all',
'--warn-error',
'--namespace=GIMarshallingTests',
@@ -163,7 +163,7 @@ if glib_dep.type_name() == 'pkgconfig'
output: '@BASENAME@.typelib',
depends: [gobject_gir, ],
command: [gircompiler, '-o', '@OUTPUT@', '@INPUT@',
- '--includedir', join_paths(meson.build_root(), 'gir'),
+ '--includedir', join_paths(build_root, 'gir'),
'--includedir', meson.current_build_dir()
],
)