summaryrefslogtreecommitdiff
path: root/tests/repository/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2010-11-16 09:46:00 -0500
committerColin Walters <walters@verbum.org>2010-11-16 09:46:00 -0500
commite4b6098e55307f602c179f37d59fbc6d0d965267 (patch)
treee118faf6eeb94068ba8f8cb558f081a344512ebc /tests/repository/Makefile.am
parente59214ec184423e0a468e7b01be4a38acacf2b31 (diff)
downloadgobject-introspection-e4b6098e55307f602c179f37d59fbc6d0d965267.tar.gz
Fix tests to look in correct directory for typelibs
With nonrecursive they're in $(top_builddir) now
Diffstat (limited to 'tests/repository/Makefile.am')
-rw-r--r--tests/repository/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/repository/Makefile.am b/tests/repository/Makefile.am
index b7ed21c0..a4557a9c 100644
--- a/tests/repository/Makefile.am
+++ b/tests/repository/Makefile.am
@@ -13,5 +13,5 @@ gitestthrows_CPPFLAGS = $(GIREPO_CFLAGS) -I$(top_srcdir)/girepository
gitestthrows_LDADD = $(top_builddir)/libgirepository-1.0.la $(GIREPO_LIBS)
TESTS = gitestrepo gitestthrows
-TESTS_ENVIRONMENT=env top_builddir="$(top_builddir)" \
+TESTS_ENVIRONMENT=env GI_TYPELIB_PATH=$(top_builddir) \
XDG_DATA_DIRS="$(top_srcdir)/gir:$(XDG_DATA_DIRS)" $(DEBUG)