summaryrefslogtreecommitdiff
path: root/tests/scanner/Makefile.am
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2018-07-22 13:52:20 +0200
committerChristoph Reiter <reiter.christoph@gmail.com>2018-07-22 14:16:21 +0200
commitba70ffe57a7cb833871146eb09d1fefcbe560512 (patch)
treea1fd1c77ee90468e87a983a74985a2b0b425ad1a /tests/scanner/Makefile.am
parent8c0f53a1e28d6d8099d2faaa1f440fee06782d27 (diff)
downloadgobject-introspection-ba70ffe57a7cb833871146eb09d1fefcbe560512.tar.gz
gi-tester: Port to Python
Removes the dependency on bash there, so we can potentially use it on Windows as well. Not integrated with meson yet, but will hopefully make it easier to do so.
Diffstat (limited to 'tests/scanner/Makefile.am')
-rw-r--r--tests/scanner/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/scanner/Makefile.am b/tests/scanner/Makefile.am
index 279addfe..5322b7b4 100644
--- a/tests/scanner/Makefile.am
+++ b/tests/scanner/Makefile.am
@@ -237,7 +237,7 @@ TESTS = $(CHECKGIRS) $(CHECKDOCS) $(TYPELIBS) $(PYTESTS)
TESTS_ENVIRONMENT = env srcdir=$(srcdir) top_srcdir=$(top_srcdir) builddir=$(builddir) top_builddir=$(top_builddir) \
CC="$(CC)" \
PYTHON=$(PYTHON) UNINSTALLED_INTROSPECTION_SRCDIR=$(top_srcdir)
-LOG_COMPILER = $(top_srcdir)/tests/gi-tester
+LOG_COMPILER = $(PYTHON) $(top_srcdir)/tests/gi-tester
EXTRA_DIST += \
$(PYTESTS) \