summaryrefslogtreecommitdiff
path: root/tests/scanner/meson.build
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2018-07-11 09:25:13 +0200
committerChristoph Reiter <reiter.christoph@gmail.com>2018-07-11 09:25:13 +0200
commit4770c7c9645e6bbc0f19cdf13b989f3c1fc5ae64 (patch)
tree28523933c12549ec686c33e31cbc93378d764d6f /tests/scanner/meson.build
parenta41abe1868a693387cd5cf85567cf2e0fd6c62df (diff)
downloadgobject-introspection-4770c7c9645e6bbc0f19cdf13b989f3c1fc5ae64.tar.gz
meson: skip test_transformer on Windows for now
Diffstat (limited to 'tests/scanner/meson.build')
-rw-r--r--tests/scanner/meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/tests/scanner/meson.build b/tests/scanner/meson.build
index 3458c32e..cd8df991 100644
--- a/tests/scanner/meson.build
+++ b/tests/scanner/meson.build
@@ -5,9 +5,13 @@ scanner_test_env.append('PYTHONPATH', join_paths(meson.current_build_dir(), '../
scanner_test_files = [
'test_shlibs.py',
'test_sourcescanner.py',
- 'test_transformer.py'
]
+# FIXME: Windows
+if host_system != 'windows'
+ scanner_test_files += ['test_transformer.py']
+endif
+
foreach f : scanner_test_files
test(f, python3, args: files(f), env: scanner_test_env)
endforeach