summaryrefslogtreecommitdiff
path: root/tests/scanner/meson.build
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2018-07-22 15:35:03 +0200
committerChristoph Reiter <reiter.christoph@gmail.com>2018-07-22 18:10:28 +0200
commitfc3b9c72841b00db7a594098fe7b3c245ffdb6c8 (patch)
treeeee49158a8fc2f53fedddb49b6f9132d0d70a753 /tests/scanner/meson.build
parente0d0bbec5bfc1ac91a51bf3ed386fa9aabacdae0 (diff)
downloadgobject-introspection-fc3b9c72841b00db7a594098fe7b3c245ffdb6c8.tar.gz
ci: add a msvc job
Diffstat (limited to 'tests/scanner/meson.build')
-rw-r--r--tests/scanner/meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/tests/scanner/meson.build b/tests/scanner/meson.build
index e64345a0..86c7d5da 100644
--- a/tests/scanner/meson.build
+++ b/tests/scanner/meson.build
@@ -4,7 +4,6 @@ scanner_test_env.append('PYTHONPATH', join_paths(meson.current_build_dir(), '../
scanner_test_files = [
'test_shlibs.py',
- 'test_sourcescanner.py',
]
# FIXME: Windows
@@ -12,6 +11,11 @@ if host_system != 'windows'
scanner_test_files += ['test_transformer.py']
endif
+# FIXME: MSVC
+if cc.get_id() != 'msvc'
+ scanner_test_files += ['test_sourcescanner.py']
+endif
+
foreach f : scanner_test_files
test(f, python, args: files(f), env: scanner_test_env)
endforeach