summaryrefslogtreecommitdiff
path: root/giscanner/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'giscanner/meson.build')
-rw-r--r--giscanner/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/giscanner/meson.build b/giscanner/meson.build
index 5a1e44c9..b4ec3796 100644
--- a/giscanner/meson.build
+++ b/giscanner/meson.build
@@ -79,12 +79,12 @@ giscanner_lib = static_library('giscanner',
dependencies: [glib_dep, gobject_dep, gio_dep, gmodule_dep],
)
-giscanner_pymod = py3.extension_module('_giscanner', 'giscannermodule.c',
+giscanner_pymod = python.extension_module('_giscanner', ['giscannermodule.c'],
link_with: giscanner_lib,
c_args: [gi_hidden_visibility_cflags],
include_directories : configinc,
dependencies: [glib_dep, gobject_dep, gio_dep, gmodule_dep,
- dependency('python3')],
+ python.dependency()],
install: true,
install_dir: giscannerdir,
)