summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am10
1 files changed, 3 insertions, 7 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index b6d6ebd2..56fc4796 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,18 +1,12 @@
include $(top_srcdir)/common.mk
SUBDIRS = . scanner repository offsets warn
-DIST_SUBDIRS = $(SUBDIRS)
-if BUILD_DOCTOOL
-SUBDIRS += doctool
-else
-DIST_SUBDIRS += doctool
-endif
EXTRA_DIST=
BUILT_SOURCES=
CLEANFILES=
-INCLUDES = $(GOBJECT_CFLAGS)
+AM_CFLAGS = $(GOBJECT_CFLAGS)
LIBADD = $(GOBJECT_LIBS)
testsdir = $(datadir)/gobject-introspection-1.0/tests
@@ -34,7 +28,9 @@ BUILT_SOURCES += everything.c everything.h
CLEANFILES += \
$(BUILT_SOURCES) \
everything-stamp.h \
+ Everything-1.0.gir \
Everything-1.0.typelib \
+ GIMarshallingTests-1.0.gir \
GIMarshallingTests-1.0.typelib
everything-stamp.h: Makefile