summaryrefslogtreecommitdiff
path: root/tests/scanner/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/scanner/Makefile.am')
-rw-r--r--tests/scanner/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/tests/scanner/Makefile.am b/tests/scanner/Makefile.am
index bc291b81..e3b84162 100644
--- a/tests/scanner/Makefile.am
+++ b/tests/scanner/Makefile.am
@@ -155,6 +155,11 @@ post-check:
rm -f $*.tgir; \
fi
+distclean-local:
+ @if test "$(top_builddir)" != "$(top_srcdir)"; then \
+ rm -f $(top_builddir)/tests/scanner/*.tgir; \
+ fi
+
check-local: pre-check
check-local: $(CHECKGIRS) $(CHECKTGIRS) $(TYPELIBS)