summaryrefslogtreecommitdiff
path: root/packages/gce-disk-expand
diff options
context:
space:
mode:
authorLiam Hopkins <liamh@google.com>2018-12-17 12:26:01 -0800
committerGitHub <noreply@github.com>2018-12-17 12:26:01 -0800
commit6a32dac91bac601a78ae507556c09f64f2f36456 (patch)
tree0e4469ac8c5662d55e37f12fabb2b6f91a8b1ca8 /packages/gce-disk-expand
parent82ed2182ccece359fd60ed407853a05369fa9894 (diff)
downloadgoogle-compute-image-packages-6a32dac91bac601a78ae507556c09f64f2f36456.tar.gz
workflow for deb packages (#718)
Diffstat (limited to 'packages/gce-disk-expand')
-rw-r--r--packages/gce-disk-expand/packaging/gce-disk-expand.spec3
-rwxr-xr-xpackages/gce-disk-expand/packaging/setup_deb.sh8
2 files changed, 5 insertions, 6 deletions
diff --git a/packages/gce-disk-expand/packaging/gce-disk-expand.spec b/packages/gce-disk-expand/packaging/gce-disk-expand.spec
index dec024e..d34b08d 100644
--- a/packages/gce-disk-expand/packaging/gce-disk-expand.spec
+++ b/packages/gce-disk-expand/packaging/gce-disk-expand.spec
@@ -25,8 +25,7 @@ Conflicts: dracut-modules-growroot
# Allow other files in the source that don't end up in the package.
%define _unpackaged_files_terminate_build 0
-%description Automatically resize the root partition on first boot.
-
+%description
This package resizes the root partition on first boot using parted.
%prep
diff --git a/packages/gce-disk-expand/packaging/setup_deb.sh b/packages/gce-disk-expand/packaging/setup_deb.sh
index 0764d1f..8880efe 100755
--- a/packages/gce-disk-expand/packaging/setup_deb.sh
+++ b/packages/gce-disk-expand/packaging/setup_deb.sh
@@ -22,6 +22,9 @@ if [[ $(basename "$working_dir") != $NAME ]]; then
exit 1
fi
+# Build dependencies.
+sudo apt-get -y install dh-systemd
+
# DEB creation tools.
sudo apt-get -y install debhelper devscripts build-essential
@@ -29,13 +32,10 @@ rm -rf /tmp/debpackage
mkdir /tmp/debpackage
tar czvf /tmp/debpackage/${NAME}_${VERSION}.orig.tar.gz --exclude .git --exclude packaging --transform "s/^\./${NAME}-${VERSION}/" .
-pushd /tmp/debpackage
+cd /tmp/debpackage
tar xzvf ${NAME}_${VERSION}.orig.tar.gz
cd ${NAME}-${VERSION}
-
cp -r ${working_dir}/packaging/debian ./
debuild -us -uc
-
-popd