summaryrefslogtreecommitdiff
path: root/packages/google-compute-engine-oslogin
diff options
context:
space:
mode:
authorZach Marano <zmarano@google.com>2019-07-08 12:05:41 -0700
committerGitHub <noreply@github.com>2019-07-08 12:05:41 -0700
commit0b8410b7dd7e6630ecf8c344d03c16e226d362e4 (patch)
treea3a339ff906a1967b5a7fc014c11c93fec31990a /packages/google-compute-engine-oslogin
parent962396a22d1564e687cac0779c78c05952e6d572 (diff)
downloadgoogle-compute-image-packages-0b8410b7dd7e6630ecf8c344d03c16e226d362e4.tar.gz
New package versioning (#794)
Diffstat (limited to 'packages/google-compute-engine-oslogin')
-rw-r--r--packages/google-compute-engine-oslogin/packaging/debian/changelog7
-rw-r--r--packages/google-compute-engine-oslogin/packaging/google-compute-engine-oslogin.spec3
-rwxr-xr-xpackages/google-compute-engine-oslogin/packaging/setup_deb.sh2
-rwxr-xr-xpackages/google-compute-engine-oslogin/packaging/setup_rpm.sh2
-rw-r--r--packages/google-compute-engine-oslogin/src/Makefile2
5 files changed, 12 insertions, 4 deletions
diff --git a/packages/google-compute-engine-oslogin/packaging/debian/changelog b/packages/google-compute-engine-oslogin/packaging/debian/changelog
index a09513c..d00ead0 100644
--- a/packages/google-compute-engine-oslogin/packaging/debian/changelog
+++ b/packages/google-compute-engine-oslogin/packaging/debian/changelog
@@ -1,3 +1,10 @@
+google-compute-engine-oslogin (1:20190708.00-g1) stable; urgency=medium
+
+ * Restructure Makefile and Debian control files.
+ * Add man pages.
+
+ -- Google Cloud Team <gc-team@google.com> Mon, 08 Jul 2019 10:20:01 -0700
+
google-compute-engine-oslogin (1.5.3-1) unstable; urgency=low
* Update OS Login control file for FreeBSD support.
diff --git a/packages/google-compute-engine-oslogin/packaging/google-compute-engine-oslogin.spec b/packages/google-compute-engine-oslogin/packaging/google-compute-engine-oslogin.spec
index f93dfff..d9b67bd 100644
--- a/packages/google-compute-engine-oslogin/packaging/google-compute-engine-oslogin.spec
+++ b/packages/google-compute-engine-oslogin/packaging/google-compute-engine-oslogin.spec
@@ -18,8 +18,9 @@
%endif
Name: google-compute-engine-oslogin
+Epoch: 1
Version: %{_version}
-Release: 1%{?dist}
+Release: g1%{?dist}
Summary: OS Login Functionality for Google Compute Engine
License: ASL 2.0
diff --git a/packages/google-compute-engine-oslogin/packaging/setup_deb.sh b/packages/google-compute-engine-oslogin/packaging/setup_deb.sh
index 4d64ca7..58e3649 100755
--- a/packages/google-compute-engine-oslogin/packaging/setup_deb.sh
+++ b/packages/google-compute-engine-oslogin/packaging/setup_deb.sh
@@ -14,7 +14,7 @@
# limitations under the License.
NAME="google-compute-engine-oslogin"
-VERSION="1.5.3"
+VERSION="20190708.00"
DEB=$(cut -d. -f1 </etc/debian_version)
if [[ -z $DEB ]]; then
diff --git a/packages/google-compute-engine-oslogin/packaging/setup_rpm.sh b/packages/google-compute-engine-oslogin/packaging/setup_rpm.sh
index 957257f..56e5c52 100755
--- a/packages/google-compute-engine-oslogin/packaging/setup_rpm.sh
+++ b/packages/google-compute-engine-oslogin/packaging/setup_rpm.sh
@@ -15,7 +15,7 @@
NAME="google-compute-engine-oslogin"
-VERSION="1.5.3"
+VERSION="20190708.00"
rpm_working_dir=/tmp/rpmpackage/${NAME}-${VERSION}
working_dir=${PWD}
diff --git a/packages/google-compute-engine-oslogin/src/Makefile b/packages/google-compute-engine-oslogin/src/Makefile
index 46f93e9..96ee104 100644
--- a/packages/google-compute-engine-oslogin/src/Makefile
+++ b/packages/google-compute-engine-oslogin/src/Makefile
@@ -1,7 +1,7 @@
SHELL = /bin/sh
TOPDIR = $(realpath ..)
-VERSION = 1.5.3
+VERSION = 20190708.00
CPPFLAGS = -Iinclude -I/usr/include/json-c
CXXFLAGS = -fPIC -Wall -g