summaryrefslogtreecommitdiff
path: root/packages/python-google-compute-engine/setup.py
diff options
context:
space:
mode:
authorLiam Hopkins <liamh@google.com>2018-12-14 12:44:47 -0800
committerGitHub <noreply@github.com>2018-12-14 12:44:47 -0800
commitf773905cc0a70927c7180dd60d939fbf21264c92 (patch)
treea8aa77f094f896d6689fcee711eb490822b6b1f0 /packages/python-google-compute-engine/setup.py
parent091c4251a0d5e4af7c006af747251af7d7bcee62 (diff)
downloadgoogle-compute-image-packages-f773905cc0a70927c7180dd60d939fbf21264c92.tar.gz
Repo layout changes (#688)
Diffstat (limited to 'packages/python-google-compute-engine/setup.py')
-rwxr-xr-xpackages/python-google-compute-engine/setup.py72
1 files changed, 72 insertions, 0 deletions
diff --git a/packages/python-google-compute-engine/setup.py b/packages/python-google-compute-engine/setup.py
new file mode 100755
index 0000000..8746f2f
--- /dev/null
+++ b/packages/python-google-compute-engine/setup.py
@@ -0,0 +1,72 @@
+#!/usr/bin/python
+# Copyright 2016 Google Inc. All Rights Reserved.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+"""Create a Python package of the Linux guest environment."""
+
+import glob
+import sys
+
+import setuptools
+
+install_requires = ['boto', 'setuptools']
+if sys.version_info >= (3, 6):
+ install_requires += ['distro']
+
+setuptools.setup(
+ author='Google Compute Engine Team',
+ author_email='gc-team@google.com',
+ description='Google Compute Engine',
+ include_package_data=True,
+ install_requires=install_requires,
+ license='Apache Software License',
+ long_description='Google Compute Engine guest environment.',
+ name='google-compute-engine',
+ packages=setuptools.find_packages(),
+ url='https://github.com/GoogleCloudPlatform/compute-image-packages',
+ version='2.8.12',
+ # Entry points create scripts in /usr/bin that call a function.
+ entry_points={
+ 'console_scripts': [
+ 'google_accounts_daemon=google_compute_engine.accounts.accounts_daemon:main',
+ 'google_clock_skew_daemon=google_compute_engine.clock_skew.clock_skew_daemon:main',
+ 'google_instance_setup=google_compute_engine.instance_setup.instance_setup:main',
+ 'google_network_daemon=google_compute_engine.networking.network_daemon:main',
+ 'google_metadata_script_runner=google_compute_engine.metadata_scripts.script_manager:main',
+ ],
+ },
+ classifiers=[
+ 'Development Status :: 5 - Production/Stable',
+ 'Environment :: No Input/Output (Daemon)',
+ 'Intended Audience :: Developers',
+ 'Intended Audience :: System Administrators',
+ 'License :: OSI Approved :: Apache Software License',
+ 'Operating System :: POSIX :: Linux',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3.2',
+ 'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
+ 'Topic :: Internet',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+ 'Topic :: System :: Installation/Setup',
+ 'Topic :: System :: Systems Administration',
+ ],
+)