summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Adam <dev@robert-adam.de>2022-06-28 10:47:00 +0200
committerRobert Adam <dev@robert-adam.de>2022-07-18 07:36:40 +0200
commit2d1cd6ee277ea3de5803115568341da48e90676a (patch)
treeffd5c2e4a05e53431ff3acff6b0909ebc3f6c9d9 /CMakeLists.txt
parent9406a60c7839052e4944ea4dbc8344762a89f9bd (diff)
downloadgoogletest-git-2d1cd6ee277ea3de5803115568341da48e90676a.tar.gz
Set cmake policy CMP0069
This ensures that LTO works as expected whenever the main project has it enabled.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4daf35b5..3cf5c270 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,6 +11,10 @@ if (POLICY CMP0077)
cmake_policy(SET CMP0077 NEW)
endif (POLICY CMP0077)
+if (POLICY CMP0069)
+ cmake_policy(SET CMP0069 NEW)
+endif (POLICY CMP0069)
+
project(googletest-distribution)
set(GOOGLETEST_VERSION 1.11.0)