summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorpeter <peter_jiachen@163.com>2018-10-24 12:17:06 +0800
committerpeter <peter_jiachen@163.com>2018-10-24 12:17:06 +0800
commit478a518590901cf3da0868ae553c4ed7f7cf54e1 (patch)
tree7d7e0912dcb42c71933e78e9b84a54471e15a314 /CMakeLists.txt
parentf6dadcf1f1727b087ac28fdd98d02356695d6a66 (diff)
downloadgoogletest-git-478a518590901cf3da0868ae553c4ed7f7cf54e1.tar.gz
Disable extensions and force standard
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e4c09717..be14229e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,6 +4,8 @@ if (CMAKE_VERSION VERSION_LESS "3.1")
add_definitions(-std=c++11)
else()
set(CMAKE_CXX_STANDARD 11)
+ set(CMAKE_CXX_STANDARD_REQUIRED ON)
+ set(CMAKE_CXX_EXTENSIONS OFF)
endif()
if (POLICY CMP0048)