summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorHoly Wu <HolyWu@users.noreply.github.com>2018-08-10 17:19:29 +0800
committerAliaksey Kandratsenka <alkondratenko@gmail.com>2018-08-14 22:34:00 -0700
commit69867c523b334028c90f2acf22b5ae528fdc2356 (patch)
tree62086995022499623ae19f1eddf067826b103cf4 /Makefile.am
parentf2bca77aed83107197abadee0652c39e2c4c73d3 (diff)
downloadgperftools-69867c523b334028c90f2acf22b5ae528fdc2356.tar.gz
Clean up MSVC projects
1.Remove superfluous per file settings for include directory and runtime library. 2.Remove unnecessary project tcmalloc_minimal_unittest-static. We can simply build libtcmalloc_minimal as a static library and then link against the single .lib file. 3.Add separate configurations of patching and overriding facility for release mode.
Diffstat (limited to 'Makefile.am')
-rwxr-xr-xMakefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 62bc30b..04ff5af 100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -526,7 +526,6 @@ LIBS_TO_WEAKEN += libtcmalloc_minimal.la
TESTS += tcmalloc_minimal_unittest
WINDOWS_PROJECTS += vsprojects/tcmalloc_minimal_unittest/tcmalloc_minimal_unittest.vcxproj
-WINDOWS_PROJECTS += vsprojects/tmu-static/tmu-static.vcxproj
tcmalloc_minimal_unittest_SOURCES = src/tests/tcmalloc_unittest.cc \
src/tests/testutil.h src/tests/testutil.cc \
$(TCMALLOC_UNITTEST_INCLUDES)