summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorxiaoyur347 <xiaoyur347@gmail.com>2013-12-20 09:02:49 +0800
committerxiaoyur347 <xiaoyur347@gmail.com>2013-12-20 09:02:49 +0800
commit7c4888515ed93347d4793fc066cd6048e519a197 (patch)
treeb68c4f582981dce27434682be427124aa398dd82 /Makefile.am
parent7bd193bca97d93b43ff6c824bc9f39227329312f (diff)
downloadgperftools-7c4888515ed93347d4793fc066cd6048e519a197.tar.gz
add uclibc support
* some variables defined with "char *" should be modified to "const char*" * For uclibc, glibc's "void malloc_stats(void)" should be "void malloc_stats(FILE *)", is commented now. * For uclibc, __sbrk is with attribute "hidden", so we use mmap allocator for uclibc.
Diffstat (limited to 'Makefile.am')
-rwxr-xr-x[-rw-r--r--]Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d269ed0..b0a9dfb 100644..100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -662,7 +662,7 @@ if GCC
malloc_extension_c_test_CFLAGS += -ansi
endif GCC
malloc_extension_c_test_LDFLAGS = $(PTHREAD_CFLAGS) $(TCMALLOC_FLAGS)
-malloc_extension_c_test_LDADD = $(LIBTCMALLOC_MINIMAL) $(PTHREAD_LIBS)
+malloc_extension_c_test_LDADD = $(LIBTCMALLOC_MINIMAL) $(PTHREAD_LIBS) -lstdc++
endif !ENABLE_STATIC
endif !MINGW