summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAliaksey Kandratsenka <alkondratenko@gmail.com>2021-02-07 11:59:44 -0800
committerAliaksey Kandratsenka <alkondratenko@gmail.com>2021-02-14 22:11:09 -0800
commitf4aa2a435eed63fc047448635f705a9c6037bd97 (patch)
treee853cd2094dfad393acf2939edfef9592e7601ca /Makefile.am
parent17bab484aea43cf1a5247c823e036dfb52f5d92b (diff)
downloadgperftools-f4aa2a435eed63fc047448635f705a9c6037bd97.tar.gz
implement generic frame pointer backtracer
This supports frame pointer backtracing on x86-64, aarch64 and riscv-s (should work for both 32 and 64 bits). Also added is detection of borked libunwind on aarch64-s. In this case frame pointer unwinder is preferred.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 730582e..d93300d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -331,6 +331,7 @@ if WITH_STACK_TRACE
### The header files we use. We divide into categories based on directory
S_STACKTRACE_INCLUDES = src/stacktrace_impl_setup-inl.h \
src/stacktrace_generic-inl.h \
+ src/stacktrace_generic_fp-inl.h \
src/stacktrace_libgcc-inl.h \
src/stacktrace_libunwind-inl.h \
src/stacktrace_arm-inl.h \