summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2004-09-08 19:03:44 +0000
committerEric S. Raymond <esr@thyrsus.com>2004-09-08 19:03:44 +0000
commit038598b32037b5c21e52ea1fc6f634b46256c2b6 (patch)
treed5ca01fb0bfb69dcee085b1e7d38ee65e30a6307 /Makefile.am
parentb3e6dc24f654ba2f896945a79fd81ab9db781706 (diff)
downloadgpsd-038598b32037b5c21e52ea1fc6f634b46256c2b6.tar.gz
Adapt the test code for the new API.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 73178826..c262fb1a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -34,7 +34,7 @@ gpsd_LDADD = $(LIBM) libgps.la
#
-# Build shared libgps
+# Build shared library
#
libgps_la_LDFLAGS = -version-number 1:0:0
lib_LTLIBRARIES = libgps.la
@@ -106,3 +106,6 @@ EXTRA_DIST = \
gpsd.py \
gpsprobe
+# This is not distributed
+libgps: libgps.c .libs/libgps.a
+ $(CC) -o libgps -DTESTMAIN libgps.c .libs/libgps.a