summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBernd Zeimetz <bernd@bzed.de>2010-05-14 16:23:11 +0200
committerBernd Zeimetz <bernd@bzed.de>2010-05-14 16:23:11 +0200
commit0aaecdfae03fab0f4a05c29753bbb00b29d5cf0e (patch)
tree75d6e5e5e4d991bdc6bee62ace528177bde702aa /Makefile.am
parent153c9750d37365bf7efe80d2d3087a8e85a362ac (diff)
downloadgpsd-0aaecdfae03fab0f4a05c29753bbb00b29d5cf0e.tar.gz
Build test_qgpsmm to test the QT library.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 79793e83..d2179c18 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -62,6 +62,9 @@ check_PROGRAMS = test_float test_trig test_bits test_packet test_mkgmtime test_g
if LIBGPSMM_ENABLE
check_PROGRAMS += test_gpsmm
endif
+if HAVE_QT
+check_PROGRAMS += test_qgpsmm
+endif
# List of Python scripts and modules, which are handled by setup.py.
# Required to ensure that the extensions/modules/scripts are rebuilt via
@@ -395,6 +398,16 @@ test_gpsmm_SOURCES = test_gpsmm.cpp
test_gpsmm_LDADD = $(LIBC) libgps.la -lm $(LIBUSB)
endif
+if HAVE_QT
+#
+# Build test_qgpsmm
+#
+test_qgpsmm_SOURCES = test_gpsmm.cpp
+test_qgpsmm_LDFLAGS = -Wl,-rpath,$(srcdir)/libQgpsmm
+test_qgpsmm_LDADD = $(LIBC) $(LIBUSB) $(QtNetwork_LIBS) -LlibQgpsmm -lQgpsmm
+test_qgpsmm_DEPENDENCIES = libQgpsmm/libQgpsmm.so
+endif
+
#
# Build test_bits tester
#