summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2006-07-23 21:27:19 +0000
committerEric S. Raymond <esr@thyrsus.com>2006-07-23 21:27:19 +0000
commit0b6ad90a01e9cc8fbd258952e30f1778b6c97588 (patch)
tree1dbf84b879341245c5a9730f7fb25bb27b71e169 /Makefile.am
parent56dfc2460710cef912a5fdf6eb2a5e95ca452a34 (diff)
downloadgpsd-0b6ad90a01e9cc8fbd258952e30f1778b6c97588.tar.gz
Pipe (-p) option split into -1 and -p options. New test added.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 2679e7a3..eefc6960 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -293,7 +293,7 @@ splint:
# that affects the low-order digits of the track field in the O response.
gps-regress: gpsd
@echo "Testing the daemon..."
- @for f in test/*.log; do gpsfake -b -p $${f} | grep -v "^GPSD,X" >test/test.chk; diff -ub $${f}.chk test/test.chk; done; rm test/test.chk
+ @for f in test/*.log; do gpsfake -1 -b -p $${f} | grep -v "^GPSD,X" >test/test.chk; diff -ub $${f}.chk test/test.chk; done; rm test/test.chk
# Test that super-raw mode works. Compare each logfile against itself
# dumped through the daemon running in R=2 mode. (This test is not
@@ -304,7 +304,7 @@ raw-regress:
# Build the regression tests for the daemon.
gps-makeregress: gpsd
- @for f in test/*.log; do gpsfake -b -p $${f} | grep -v "^GPSD,X" >$${f}.chk; done
+ @for f in test/*.log; do gpsfake -1 -b -p $${f} | grep -v "^GPSD,X" >$${f}.chk; done
# Regression-test the RTCM decoder.
rtcm-regress: rtcmdecode