summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2010-12-01 17:54:40 -0500
committerEric S. Raymond <esr@thyrsus.com>2010-12-01 17:54:40 -0500
commit25845cfe248878c2d4ca3f530f3514fd751bd496 (patch)
treec254ced4dd525a2355955182b8166815e87e9308 /Makefile.am
parentf71a648461bf33c0045d27772cc2a93a3fd94533 (diff)
downloadgpsd-25845cfe248878c2d4ca3f530f3514fd751bd496.tar.gz
A production for deheader scans.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index cbfe4d46..23e13a69 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,6 +5,9 @@
# BSD terms apply: see the file COPYING in the distribution root for details.
#
+# The deheader production uses this to pass in stop-on-error flags
+CFLAGS += $(MORECFLAGS)
+
ACLOCAL_AMDFLAGS = -I m4
CLEANFILES =
@@ -647,6 +650,10 @@ cppcheck: gpsd.h packet_names.h
xmllint: $(XML)
for xml in $(XML); do xmllint --nonet --noout --valid $$xml; done
+# Use deheader to remove headers not required
+deheader:
+ deheader -r -i gpsd_config.h -m "MORECFLAGS='-Werror -Wfatal-errors' make -e"
+
# Re-indent the codebase in a uniform style for readability.
INDENT_FILES = $(gpsd_c_sources) $(libgpsd_c_sources) $(libgps_c_sources) \
$(cgps_SOURCES) $(gpsmon_SOURCES) $(gpspipe_SOURCES) \