summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2006-12-04 19:04:28 +0000
committerEric S. Raymond <esr@thyrsus.com>2006-12-04 19:04:28 +0000
commit28a92bdce0bfb2da046e9d5fa47511d7c3054399 (patch)
tree90bb816b7e5a3f908c8cc594d7983e231885a147 /Makefile.am
parentf057cf1fa3095056370f5dd39af2a8ec3b0ce38c (diff)
downloadgpsd-28a92bdce0bfb2da046e9d5fa47511d7c3054399.tar.gz
First cut at a Python binding for the packet.c module.
It builds and imports without errors, but has not been tested yet.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2f2e7f54..6fb4fa07 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -147,6 +147,16 @@ nodist_libgps_la_SOURCES = packet_names.h
libgps_la_LIBADD = $(LIBM) $(LIBC) $(LIBNSL) $(LIBSOCKET) $(LIBPTHREAD)
#
+# Build Python binding
+#
+PYEXTENSIONS = gpspacket.so
+
+noinst_SCRIPTS = gpspacket.so
+
+gpspacket.so: gpspacket.c libgps.la
+ python setup.py build_ext --inplace
+
+#
# Build gpsmm_test
#
gpsmm_test_SOURCES = gpsmm_test.cpp
@@ -271,7 +281,7 @@ EXTRA_DIST = \
striplog \
invert-bitfields.pl
-CLEANFILES = packet_names.h floattest *.core
+CLEANFILES = packet_names.h floattest *.core $(PYEXTENSIONS)
# This is not distributed
libgps: libgps.c .libs/libgps.a