summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2009-12-02 11:42:09 +0000
committerEric S. Raymond <esr@thyrsus.com>2009-12-02 11:42:09 +0000
commit2a2dda5ec5fff2c511468dfb070fe471a4f195d9 (patch)
treefa45c31a79f93351ae67d506cc5ef989b8640b30 /Makefile.am
parentdf4c6b35ec3679a4930c2c7948aa24a525adf492 (diff)
downloadgpsd-2a2dda5ec5fff2c511468dfb070fe471a4f195d9.tar.gz
Solve the libgps.0.0.0 problem.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 287e8061..64781567 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -222,11 +222,12 @@ maskdump.c: gpsd.h-tail maskaudit.py
libgps_la_SOURCES = $(libgpsd_c_sources) $(libgpsd_h_sources) \
driver_rtcm2.h packet_states.h
+# Warning: This overrides autoconf's normal link-line generatyion process
if LIBGPSMM_ENABLE
libgps_la_SOURCES += libgpsmm.cpp
-libgps_la_LINK = /bin/sh ./libtool --tag=CXX --mode=link g++ -o $@
+libgps_la_LINK = /bin/sh ./libtool --tag=CXX --mode=link g++ $(libgps_la_LDFLAGS) -o $@
else
-libgps_la_LINK = /bin/sh ./libtool --tag=CC --mode=link gcc -o $@
+libgps_la_LINK = /bin/sh ./libtool --tag=CC --mode=link gcc $(libgps_la_LDFLAGS) -o $@
endif
nodist_libgps_la_SOURCES = packet_names.h ais_json.i