summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2005-07-22 14:52:10 +0000
committerEric S. Raymond <esr@thyrsus.com>2005-07-22 14:52:10 +0000
commit2c4d1a79fc2de0b6045c82c2d1ea5ee816f755e6 (patch)
tree6dc2cc4ee015026009b35b79ae1eb9e9812eb5d2 /Makefile.am
parentbf54e8892d8f6d93873c09646fdc3eef077e72ca (diff)
downloadgpsd-2c4d1a79fc2de0b6045c82c2d1ea5ee816f755e6.tar.gz
Avoid a splint problem.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 4e7f0452..973e2484 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -86,8 +86,6 @@ libgps_c_sources = \
ntpshm.c \
libgps.c \
packet.c \
- packet_states.h \
- packet_names.h \
gpsutils.c \
geoid.c \
dgpsip.c \
@@ -101,7 +99,12 @@ libgps_c_sources = \
packet_names.h: packet_states.h
sed -e '/^ *\([A-Z][A-Z0-9_]*\),/s// "\1",/' <packet_states.h >packet_names.h
-libgps_la_SOURCES = $(libgps_c_sources) libgpsmm.cpp
+libgps_la_SOURCES = \
+ $(libgps_c_sources)
+ libgpsmm.cpp \
+ packet_states.h \
+ packet_names.h
+
libgps_la_LIBADD = $(LIBM) $(LIBC) $(LIBNSL) $(LIBSOCKET) $(LIBPTHREAD)
#