summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2010-04-13 19:50:15 -0400
committerEric S. Raymond <esr@thyrsus.com>2010-04-13 19:50:15 -0400
commit2dceafd81024bbb005e088723cb591425962e090 (patch)
tree4164fef7581f2a7159865839599e64b68d8fb45f /Makefile.am
parentb8a6c544980fa6a03597ebcb5aa6b00870563da6 (diff)
downloadgpsd-2dceafd81024bbb005e088723cb591425962e090.tar.gz
Attempt to undo some of indent's messing about.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 001baedc..9e6d7140 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -521,9 +521,15 @@ cppcheck: gpsd.h packet_names.h
# Re-indenting to a uniform style would be nice, and we leave this here
# as a rough guide to the project style, but it turns out that indent is
# an excessively blunt instrument.
+INDENT_SOURCES = $(gpsd_c_sources) $(libgpsd_c_sources) \
+ $(cgps_SOURCES) $(gpsmon_SOURCES) $(gpspipe_SOURCES) \
+ $(test_bits_SOURCES) $(test_packet_SOURCES) \
+ $(test_mkgmtime_SOURCES) $(test_geoid_SOURCES) $(test_json_SOURCES)
+INDENT_OPTIONS = -i4 -npsl -ce -br -cbi0 -bli0 -ncs -npcs -nfca
indent:
chmod u+w *maskdump.c
- indent -i4 -npsl -ce -br -cbi0 -bli0 -ncs -npcs -nfca $(gpsd_c_sources) $(libgpsd_c_sources) $(cgps_SOURCES) $(gpsmon_SOURCES) $(gpspipe_SOURCES) $(test_bits_SOURCES) $(test_packet_SOURCES) $(test_mkgmtime_SOURCES) $(test_geoid_SOURCES) $(test_json_SOURCES)
+ indent $(INDENT_OPTIONS) $(INDENT_SOURCES)
+ replace '@ \\*/' '@\\*/' $(INDENT_SOURCES)
chmod u-w *maskdump.c
@echo "Diff lines:" `git diff | wc -l`