summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2010-12-17 02:24:28 -0500
committerEric S. Raymond <esr@thyrsus.com>2010-12-17 02:24:28 -0500
commit459f1c5a36c31d8ac3d87d68a4f51c1852c1f064 (patch)
treea5116aa4705fcd86705caaa7ecba3a7436bfb30f /Makefile.am
parentf93f866f0f8cbc9cc6ed2fbf295926c8a71f9534 (diff)
downloadgpsd-459f1c5a36c31d8ac3d87d68a4f51c1852c1f064.tar.gz
Factor out our implementation of daemon(3) and use it as a fallback...
...in case the local OS doesn't have it (it's not SuS/POSIX portable). >From an idea by Gleb Smirnoff. but with cleaner build-system integration.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 95f00a98..46532074 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -175,6 +175,10 @@ libgps_c_sources = \
shared_json.c \
strl.c
+if NO_DAEMON3
+libgps_c_sources += daemon.c
+endif
+
libgpsd_c_sources = \
bits.c \
bsd-base64.c \