summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2004-09-09 11:42:09 +0000
committerEric S. Raymond <esr@thyrsus.com>2004-09-09 11:42:09 +0000
commit48d6b7003d7a739f762c51034feb775acf7f476b (patch)
tree73c0f43b589e8a838c239f496c55d0a352581bbe /Makefile.am
parent19468881fdaa6d8f27f60669851a07fd8ac04161 (diff)
downloadgpsd-48d6b7003d7a739f762c51034feb775acf7f476b.tar.gz
Conditional-build fixes for Motifless systems, from Jens Oberender.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 5f0b7028..a2c5e3a6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,13 @@
# Copyright (C) 2004 Jens Oberender <j.obi at troja.net>
-EXTRA_PROGRAMS = gps xgpsspeed
-bin_PROGRAMS = $(MISSING_MOTIF) gps xgpsspeed
+#
+# Build stuff depending on Motif
+#
+if HAVE_MOTIF
+BUILD_PROGS = gps xgpsspeed
+endif
+
+bin_PROGRAMS = $(BUILD_PROGS)
bin_SCRIPTS = gpsprobe
#
@@ -11,7 +17,6 @@ gps_SOURCES = display.c gps.c
gps_CFLAGS = $(X_CFLAGS)
gps_LDADD = $(LIBM) $(LIBC) $(LIBNSL) $(LIBSOCKET) $(XM_LIBS) $(X_LIBS) $(X_PRE_LIBS) libgps.la
-
#
# Build xgpsspeed
#