summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaul Fertser <fercerpav@gmail.com>2011-01-10 23:48:33 +0300
committerEric S. Raymond <esr@thyrsus.com>2011-01-11 09:37:00 -0500
commit4adbf95a9fcb50e5c9558c324b888bfb735a878b (patch)
tree393510c532dda8a14d169dadf71768858879cec7 /Makefile.am
parent7781fa6a47c5fafecfc25c36b26531966615201a (diff)
downloadgpsd-4adbf95a9fcb50e5c9558c324b888bfb735a878b.tar.gz
Add device activation/deactivation hook
This adds possibility for a system integrator to define custom hooks that are executed on device activation and deactivation. Since there's no standard way to control power consumption of different gps devices out there, the designers of embedded appliances usually provide a system-specific way to do power management of a GPS module. This might be e.g. a power_on sysfs node. This patch adds an opportunity for a system integrator to transparently enable power for device as soon as any client starts requesting data from it and to disable power on deactivation (which normally happens 60 seconds after the last client who needed it disconnected). Signed-off-by: Eric S. Raymond <esr@thyrsus.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index b7ad6a51..88d5bd43 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,7 +6,7 @@
#
# The deheader production uses this to pass in stop-on-error flags
-CFLAGS += $(MORECFLAGS)
+CFLAGS += $(MORECFLAGS) -DSYSCONFDIR=\"$(sysconfdir)\"
ACLOCAL_AMDFLAGS = -I m4
@@ -607,7 +607,7 @@ libgps: libgps_core.c gps.h .libs/libgps.a
# Report splint warnings
-SPLINTOPTS = -I/usr/include/dbus-1.0/ $(LIBUSB_CFLAGS) +quiet
+SPLINTOPTS = -I/usr/include/dbus-1.0/ -DSYSCONFDIR=\"$(sysconfdir)\" $(LIBUSB_CFLAGS) +quiet
splint: gpsd.h packet_names.h
@echo "Running splint on daemon..."
-splint $(SPLINTOPTS) -exportlocal -redef $(gpsd_c_sources)