summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBernd Zeimetz <bernd@bzed.de>2010-07-05 11:10:53 +0200
committerBernd Zeimetz <bernd@bzed.de>2010-07-05 11:13:19 +0200
commit7793c8c728dc29b9b49a868b15aea5be36e57364 (patch)
tree5c0c3cfcd33f5945c589fad410f1cc41436d2e79 /Makefile.am
parent946e8d41d100d447b8239b0cc5571b883bf2a67a (diff)
downloadgpsd-7793c8c728dc29b9b49a868b15aea5be36e57364.tar.gz
Enhance the libQgpsmm build process.
We now pass libdir and includedir from autotools to qmake to ensure the library is installed in the same location. This should avoid an issue on some distributions where 64bit libraries are living in a different directory. There should be a better way to let qmake figure this out, but for now this should work.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index c6ccca44..ac8cee84 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -346,9 +346,11 @@ QMAKE_OPTS = "PREFIX=${prefix}" \
"QMAKE_CC=$(CC)" \
"QMAKE_CFLAGS+=$(CFLAGS)" \
"QMAKE_LFLAGS+=$(LDFLAGS)" \
- "VERSION=$(libgps_VERSION)"
+ "VERSION=$(libgps_VERSION)" \
+ "TARGET_LIBDIR=${libdir}" \
+ "TARGET_INCLUDEDIR=${includedir}"
-libQgpsmm/Makefile: libQgpsmm/libQgpsmm.pro
+libQgpsmm/Makefile: libQgpsmm/libQgpsmm.pro gpsd.h ais_json.i
cd $(srcdir)/libQgpsmm && $(QMAKE) $(QMAKE_OPTS)
# Yet another multiple-outputs hack:
$(QTLIBS): stamp-qt