summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2005-07-13 14:01:33 +0000
committerEric S. Raymond <esr@thyrsus.com>2005-07-13 14:01:33 +0000
commit7fb9bc2f37904da8d96315783364c93a13bbc598 (patch)
treeabbcf73ca09d1bf7828d80be264475498f863f16 /Makefile.am
parent187c29a97cd488143a3220cc7a8868a5dfbf3ddb (diff)
downloadgpsd-7fb9bc2f37904da8d96315783364c93a13bbc598.tar.gz
Create a regression test for the RTCM decoder. Add a useful header comment.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am37
1 files changed, 26 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index 5ddde9e0..dc198612 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -190,16 +190,6 @@ EXTRA_DIST = \
libgps: libgps.c .libs/libgps.a
$(CC) -o libgps -lm -DTESTMAIN -g libgps.c .libs/libgps.a
-# Regression-test the daemon
-# This requires gcc4; there's been some change in the math libraries since
-# gcc3 that affects the low-order digits of the track field in the O response.
-testregress:
- @for f in test/*.log; do gpsfake -b -p $${f} | grep -v "^GPSD,X" >test/test.chk; diff -ub $${f}.chk test/test.chk; done; rm test/test.chk
-
-# Build the regression tests
-makeregress:
- @for f in test/*.log; do gpsfake -b -p $${f} | grep -v "^GPSD,X" >$${f}.chk; done
-
# Report splint warnings
splint:
@echo "Running splint on daemon and libraries..."
@@ -211,4 +201,29 @@ splint:
@echo "Running splint on sirfmon..."
-splint $(sirfmon_SOURCES)
@echo "Running splint on bits test harness..."
- -splint bits.c
+ -splint bits.c @echo "Running splint on rtcmdecode..."
+ -splint rtcmdecode.c
+
+#
+# Regression tests begin here
+#
+
+# Regression-test the daemon
+# This requires gcc4; there's been some change in the math libraries since
+# gcc3 that affects the low-order digits of the track field in the O response.
+gps-regress:
+ @for f in test/*.log; do gpsfake -b -p $${f} | grep -v "^GPSD,X" >test/test.chk; diff -ub $${f}.chk test/test.chk; done; rm test/test.chk
+
+# Build the regression tests for the daeomon
+gps-makeregress:
+ @for f in test/*.log; do gpsfake -b -p $${f} | grep -v "^GPSD,X" >$${f}.chk; done
+
+# Regression-test the RTCM decoder
+rtcm-regress:
+ @for f in test/*.rtcm; do rtcmdecode <$${f} >test/test.chk; diff -ub $${f}.chk test/test.chk; done; rm test/test.chk
+
+# Rebuild the RTCM regression tests
+rtcm-makeregress:
+ @for f in test/*.rtcm; do rtcmdecode <$${f} >$${f}.chk; done
+
+testregress: gps-regress rtcm-regress