summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2005-07-12 00:37:57 +0000
committerEric S. Raymond <esr@thyrsus.com>2005-07-12 00:37:57 +0000
commit808278040bb02748165cc6d1d53b732dd7ce9872 (patch)
treef878b5f5fc1b0008e6e07911ea8be2200c594b17 /Makefile.am
parentca10614ce81403e0f1d7d99db618ba283a93c02f (diff)
downloadgpsd-808278040bb02748165cc6d1d53b732dd7ce9872.tar.gz
rtcmdecode only works with -O1.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index fb819b66..cb12bf8f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,7 +16,7 @@ INCLUDES = $(DBUS_CFLAGS)
endif
bin_PROGRAMS = $(BUILD_PROGS) sirfmon
-check_PROGRAMS = gpsmm_test bits
+check_PROGRAMS = gpsmm_test bits rtcmdecode
bin_SCRIPTS = gpsprof gpsfake
#
@@ -55,6 +55,11 @@ gpsd_SOURCES = \
gpsd.c
gpsd_LDADD = $(DBUS_LIBS) $(LIBM) libgps.la -lm $(LIBPTHREAD)
+#
+# Build rtcmdecode
+#
+rtcmdecode_SOURCES = rtcmdecode,c
+rtcmdecode_CFLAGS = -O1
#
# Build sirfmon
@@ -202,6 +207,3 @@ splint:
-splint $(sirfmon_SOURCES)
@echo "Running splint on bits test harness..."
-splint bits.c
-
-rtcmdecode:
- cc -o rtcmdecode rtcmdecode.c