summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGreg Troxel <gdt@ir.bbn.com>2009-03-04 19:17:02 +0000
committerGreg Troxel <gdt@ir.bbn.com>2009-03-04 19:17:02 +0000
commit86824ecd25fb6509cd8957cb88b8bcb638e9a44c (patch)
tree78a0c999af16f3f86df05cabe30d522326bcfb85 /Makefile.am
parent2678b2232e3ccda683d20cf44d85948523a631e2 (diff)
downloadgpsd-86824ecd25fb6509cd8957cb88b8bcb638e9a44c.tar.gz
Add manpages (not makefiles as I confusedly said in my mail) to clean target.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index fbff1640..386a71b5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -227,12 +227,13 @@ if HAVE_XSLT_PROCESSOR
#
# Create Manpages
#
-man_MANS = \
+BUILT_MANPAGES = \
gpsd.8 \
gps.1 \
xgps.1 \
xgpsspeed.1 \
cgps.1 \
+ cgpxlogger.1 \
libgps.3 \
libgpsmm.3 \
libgpsd.3 \
@@ -245,6 +246,9 @@ man_MANS = \
rtcm-104.5 \
srec.5
+man_MANS = \
+ $(BUILT_MANPAGES)
+
.xml.1:
$(MANGENERATOR) $(MANFLAGS) $(MANTARGET) $<
@@ -344,7 +348,7 @@ EXTRA_DIST = \
libgpsd.pc.in \
gpscap.ini
-CLEANFILES = $(BUILT_SOURCES) test_float *.core $(PYEXTENSIONS)
+CLEANFILES = $(BUILT_SOURCES) test_float *.core $(PYEXTENSIONS) $(BUILT_MANPAGES)
pkgconfig_DATA = libgps.pc libgpsd.pc
pkgconfigdir = $(libdir)/pkgconfig