summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChris Kuethe <chris.kuethe@gmail.com>2009-06-03 22:14:23 +0000
committerChris Kuethe <chris.kuethe@gmail.com>2009-06-03 22:14:23 +0000
commit8a7d06c58868486632f82fb75225f666999f3c63 (patch)
tree4d796107d0823589e408f30dea368a386089a472 /Makefile.am
parentb2de364fa9cfacb0138fb0ab85860a4d523cce50 (diff)
downloadgpsd-8a7d06c58868486632f82fb75225f666999f3c63.tar.gz
Bye-bye gpsflash.
It's unlikely that we'll ever be able to make this ready for prime-time use without a lot more vendor assistance. If someone wants this, they can resurrect it from the version history.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 1 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index 0bac06cd..5d181dbc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -45,7 +45,7 @@ RTCM104PROGS = gpsdecode
RTCM104PAGES = $(RTCM104PAGES_DIST)
endif
-bin_PROGRAMS = $(MOTIF_PROGS) $(XAW_PROGS) $(RTCM104PROGS) $(CURSESPROGS) gpsctl gpspipe gpsflash gpxlogger lcdgps
+bin_PROGRAMS = $(MOTIF_PROGS) $(XAW_PROGS) $(RTCM104PROGS) $(CURSESPROGS) gpsctl gpspipe gpxlogger lcdgps
sbin_PROGRAMS = gpsd
check_PROGRAMS = test_float test_bits test_gpsmm test_packet test_mkgmtime test_geoid
@@ -127,12 +127,6 @@ gpsdecode_SOURCES = gpsdecode.c
gpsdecode_LDADD = $(LIBM) libgps.la -lm $(LIBPTHREAD)
#
-# Build gpsflash
-#
-gpsflash_SOURCES = gpsflash.c gpsflash.h sirfflash.c
-gpsflash_LDADD = $(LIBM) libgps.la -lm
-
-#
# Build shared libraries
#
libgps_la_LDFLAGS = -version-number 18:0:0
@@ -282,7 +276,6 @@ MANPAGES_BASE = \
gpsmon.1 \
gpsctl.1 \
gpspipe.1 \
- gpsflash.1 \
rtcm-104.5 \
srec.5
@@ -358,7 +351,6 @@ EXTRA_DIST = \
gpsdecode.xml \
rtcm-104.xml \
srec.xml \
- gpsflash.xml \
$(MANPAGES_DIST) \
xgps.ad \
xgpsspeed.ad \
@@ -417,8 +409,6 @@ splint: gpsd.h packet_names.h
-splint $(SPLINTOPTS) $(gpspipe_SOURCES)
@echo "Running splint on gpsdecode..."
-splint $(SPLINTOPTS) -exportlocal gpsdecode.c
- @echo "Running splint on gpsflash..."
- -splint $(SPLINTOPTS) $(gpsflash_SOURCES)
@echo "Running splint on test_bits test harness..."
-splint $(SPLINTOPTS) $(test_bits_SOURCES)
@echo "Running splint on test_packet test harness..."