summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2009-11-17 19:33:58 +0000
committerEric S. Raymond <esr@thyrsus.com>2009-11-17 19:33:58 +0000
commit9c9497981cc554c218d55ed15aae9217b9a159b9 (patch)
treeb21a63cb7e1ddacff340e544bfcc6719c9482daf /Makefile.am
parentd678f81143a57f9a61e898c272f95da696848c62 (diff)
downloadgpsd-9c9497981cc554c218d55ed15aae9217b9a159b9.tar.gz
Give up on indent, documenting the reason.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 8f9775d1..88543ae2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -481,7 +481,8 @@ splint: gpsd.h packet_names.h
# Re-indenting to a uniform style would be nice, and we leave this hear
# as a rough guide to the project style, but it turns out that indent is
# an excessively blunt instrument. As of 2.2.10 it doesn't honor -nfca
-# and produces loads of spurious changes to splint directives.
+# and produces loads of spurious changes to splint directives. Nor does
+# it seem to honor -npcs.
indent:
chmod u+w maskdump.c
indent -i4 -br -cbi0 -bli0 -ncs -npcs -nfca $(gpsd_c_sources) $(libgpsd_c_sources)