summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2010-12-03 05:06:19 -0500
committerEric S. Raymond <esr@thyrsus.com>2010-12-03 05:06:19 -0500
commitaf7476965bde4d4564b640ef503e37553302fdf8 (patch)
tree945f64abab8744b7e005398388ef0ac27ece35c1 /Makefile.am
parent28ff7510067a5609bc6eec1c4f9ec178488dadf5 (diff)
downloadgpsd-af7476965bde4d4564b640ef503e37553302fdf8.tar.gz
Clean up the code base and add switches so deheader runs clean.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index fd0529e5..e00dc3c4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -651,9 +651,10 @@ xmllint: $(XML)
for xml in $(XML); do xmllint --nonet --noout --valid $$xml; done
# Use deheader to remove headers not required
+ENABLES = -DBINARY_ENABLE -DDEBUG -DDBUS_ENABLE -DPPS_ENABLE -DRAW_ENABLE
deheader:
make clean
- deheader -r -i gpsd_config.h -i gpsd.h -m "MORECFLAGS='-Werror -Wfatal-errors' make -e"
+ deheader -r -i gpsd_config.h -i gpsd.h -m "MORECFLAGS='-Werror -Wfatal-errors $(ENABLES)' make -e"
make clean
# Re-indent the codebase in a uniform style for readability.