summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChris Kuethe <chris.kuethe@gmail.com>2007-03-07 22:53:14 +0000
committerChris Kuethe <chris.kuethe@gmail.com>2007-03-07 22:53:14 +0000
commitafea2ed749276f6b8e9e2d1aba46ac6b3bb31859 (patch)
tree63e14b26c0a4d71c179b688c4750d17cc1df30ac /Makefile.am
parent8b70e428a620d513429ff828ab6efd0977d21fee (diff)
downloadgpsd-afea2ed749276f6b8e9e2d1aba46ac6b3bb31859.tar.gz
Install gpsd_config.h like I intented to.
Inspired by a diff from "Iain", who is with the gnome org. Iain's patch also included gpsd_config.h in the headers; I chose to not include that. I'm not really keen on nested headers. The patch also included gpsd_config.h in the distribution tarball, which we don't need to do.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 8123d07e..ca94b195 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -152,7 +152,7 @@ packet_names.h: packet_states.h
sed -e '/^ *\([A-Z][A-Z0-9_]*\),/s// "\1",/' -e '/_states/s//_names/' < `test -f 'packet_states.h' || echo '$(srcdir)/'`packet_states.h > packet_names.h
libgps_la_SOURCES = $(libgps_c_sources) rtcm.h libgpsmm.cpp packet_states.h
-nodist_libgps_la_SOURCES = gpsd_config.h packet_names.h
+nodist_libgps_la_SOURCES = packet_names.h
libgps_la_LIBADD = $(LIBM) $(LIBC) $(LIBNSL) $(LIBSOCKET) $(LIBPTHREAD)
#
@@ -255,6 +255,7 @@ gpsflash.1: gpsflash.xml
endif
noinst_HEADERS = ubx.h
+nodist_include_HEADERS = gpsd_config.h
include_HEADERS = gps.h gpsd.h libgpsmm.h
EXTRA_DIST = \