summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2009-11-07 16:01:44 +0000
committerEric S. Raymond <esr@thyrsus.com>2009-11-07 16:01:44 +0000
commitb8640c1a2cf6dff7a5c9053051afb2d0ce1b9c69 (patch)
tree5fc3cd2293028e12ac0a5491a6034fa2b31a6f63 /Makefile.am
parent4191ef0a93b880436b72d8e9e869defbecf34542 (diff)
downloadgpsd-b8640c1a2cf6dff7a5c9053051afb2d0ce1b9c69.tar.gz
Prevent setup.py from trying to install manpages...
...if there is no generator (xmlto or xsltproc) for them.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0fe2374d..9b8c253e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -240,7 +240,8 @@ stamp-python-modules: gpspacket.c gpslib.c libgps.la setup.py
$(PYTHON) setup.py build_ext \
--build-lib '$(srcdir)' \
--build-temp '$(srcdir)/build' \
- --include-dirs '$(srcdir):.'
+ --include-dirs '$(srcdir):.'\
+ --mangenerator '$(MANGENERATOR)'
@mv -f '$@.tmp' '$@'
CLEANFILES += stamp-python-modules stamp-python-modules.tmp
endif