summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2005-12-20 17:35:49 +0000
committerEric S. Raymond <esr@thyrsus.com>2005-12-20 17:35:49 +0000
commitbdcf3c515257df3ac5f209b908293c82a32818c8 (patch)
treeda08108936f8d33f1e113447c9942840e78b4c68 /Makefile.am
parent9dc431e351fd953288b252eafdde227fa64d8b7a (diff)
downloadgpsd-bdcf3c515257df3ac5f209b908293c82a32818c8.tar.gz
Enable eveything to build when RTCM104 is configured out.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 7c748ba7..51df9df2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -18,7 +18,12 @@ DBUSPAGES = gpxlogger.1
gpxlogger_LDADD = $(DBUS_GLIB_LIBS)
endif
-bin_PROGRAMS = $(DBUSPROGS) $(MOTIF_PROGS) sirfmon rtcmdecode gpspipe gpsflash cgps cgpxlogger
+if HAVE_RTCM104
+RTCM104PROGS = rtcmdecode
+RTCM104PAGES = rtcmdecode.1
+endif
+
+bin_PROGRAMS = $(DBUSPROGS) $(MOTIF_PROGS) $(RTCM104PROGS) sirfmon gpspipe gpsflash cgps cgpxlogger
dist_bin_SCRIPTS = gpsprof gpsfake
sbin_PROGRAMS = gpsd
check_PROGRAMS = bits_test gpsmm_test packet_test
@@ -159,8 +164,8 @@ man_MANS = \
gpsfake.1 \
sirfmon.1 \
$(DBUSPAGES) \
+ $(RTCM104PAGES) \
gpspipe.1 \
- rtcmdecode.1 \
gpsflash.1 \
rtcm-104.5 \
srec.5