summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2011-01-18 09:22:18 -0500
committerEric S. Raymond <esr@thyrsus.com>2011-01-18 09:22:18 -0500
commitc421568303779f185237356e466a8cfb84b27826 (patch)
treee322d51d353b8ccfc74426275351c0096f27f6ef /Makefile.am
parentc6c7d944e9bfa1e6619ac2f442fd69dde46992e0 (diff)
downloadgpsd-c421568303779f185237356e466a8cfb84b27826.tar.gz
Keep leapcheck.i in the repo so we can rebuild without net.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index e3b9c8cf..78915549 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -209,7 +209,7 @@ libgpsd_h_sources = \
libgpsd_la_LDFLAGS = $(LIBUSB_LIBS) $(BLUEZ_LIBS)
-BUILT_SOURCES = packet_names.h gpsd.h revision.h ais_json.i gps_maskdump.c gpsd_maskdump.c leapcheck.i
+BUILT_SOURCES = packet_names.h gpsd.h revision.h ais_json.i gps_maskdump.c gpsd_maskdump.c
packet_names.h: packet_states.h
rm -f packet_names.h && \
@@ -244,10 +244,9 @@ gpsd_maskdump.c: gpsd.h maskaudit.py
$(PYTHON) maskaudit.py -d >gpsd_maskdump.c && \
chmod a-w gpsd_maskdump.c
+# This gets kept in the repo so we can build without Internet access
leapcheck.i: leapsecond.py
- rm -f leapcheck.i && \
- $(PYTHON) leapsecond.py -c leapcheck.i && \
- chmod a-w leapcheck.i
+ $(PYTHON) leapsecond.py -c leapcheck.i
libgps_la_SOURCES = $(libgps_c_sources)